Virtual Open Schooling Online courses available at Virtual Open Schooling (VOS), for more details kindly click here!
NIOS Silver Jubilee Year
NIOS

Getting Started with OpenOffice Writer

From NIOS
Jump to: navigation, search
Previous Page Home Page Next Page
ICT Applications


Writer is the word processor component of the OpenOffice Suite. It allows you to various kind of documents such as letters, reports, newsletters, tables, form letters, brochures, and web pages. Writer has all the features of any standard word processor such as spelling check, thesaurus, hyphenation, auto-correct, find and replace, automatic generation of tables of contents and indexes, mail merge and others. In addition to the standard features of a word processor, Writer also provides many more important features to create professional documents.

Objectives

After going through this lesson you would be able to:

  • explain basic features of Writer, word processor of OpenOffice Suite
  • define Writer’s document defaults;
  • move around in a document more quickly and efficiently;
  • manage Writer files and printing.

Main Features of OpenOffice Writer

  • Create documents fast, using built-in and custom templates and styles.
  • Manage large documents using various features like the ability to create table of contents, index, and cross references.;
  • With the help of mail merge, quickly create and merge documents for mass mailings or create mailing labels;
  • Easily create and format tables using the features like AutoFormat.
  • Auto-Correct and Auto-Format features rectify typo-graphical errors automatically and allows to use predefined shortcuts and typing patterns to quickly format the documents.
  • It allows embedding or linking of graphics, spreadsheets, and other objects.
  • The print zoom facility scales a document on different paper sizes, and allows to print out multiple pages on a single sheet of paper.
  • The nested tables feature supports putting one table inside another table.
  • The picture bullets make it easy to insert tiny pictures before each item in a list.
  • Collect and paste lets copy more than one item to the clipboard at a time. One can collect information from many sources and paste it into one place.
  • By putting Writer documents on the Web server, one can share information with other people.
  • The multilingual features of Writer allows to type different languages in the same document.
  • Save documents in HTML format. Also create Web Pages using Web Page Wizard.
  • Writer has a powerful feature of built-in drawing tools which allows to create various drawings and graphics.
  • Export your Writer document to PDF including bookmarks.

Starting OpenOffice Writer

You can start your OpenOffice.org Writer in may ways. The most common way of starting any program is by using System Menu through Start button:

1. Click on the Start button.

2. Start menu->All Programmes->OpenOffice->OpenOffice.org Writer.

In few seconds you will see OpenOffice.org Writer screen on the monitor.

You can also start your OpenOffice.org Writer program by simply clicking on OpenOffice.org Shortcut on your desktop and then click the Text Document.

Starting from an existing document

You can start OpenOffice.org by double-clicking the filename of an OpenOffice.org document in a file manager such as Windows Explorer. The appropriate component of OpenOffice.org will start and the document will be loaded.

You can spot an OpenOffice.org Writer document by its icon: Writer-2.png

Note for Windows users

If you have associated Microsoft Office file types with OpenOffice.org, then when you double-click on a *.doc (Word) file, it opens in Writer; *.xls (Excel) files open in Calc, and *.ppt (PowerPoint) files open in Impress.

OpenOffice Writer Interface

The main screen of OpenOffice Writer workspace contains a number of menu objects. We will discuss the main Writer workspace in Print Layouthere.

Writer-1.png
The main screen of openoffice writer

Menus

The Menu bar is located across the top of the Writer window, just below the Title bar. When you choose one of the menus listed below, a sub-menu drops down to show the commands for that sub-menu.

  • File menu contains commands that apply to the entire document such as Open..., Save, and Export as PDF....
  • Edit menu contains commands for editing the document such as Undo: xxx (where xxx is the command to undo) and Find & Replace.... It also contains commands to cut, copy, and paste selected parts of your document.
  • View menu contains commands for controlling the display of the document such as Zoom... and Web Layout.
  • Insert menu contains commands for inserting elements into your document such as headers, footers, and pictures.
  • Format menu contains commands for formatting the layout of your document, such as Styles and Formatting, Paragraph, and Bullets and Numbering.
  • Table menu shows all commands to insert and edit a table in a text document.
  • Tools menu contains functions such as Spelling and Grammar, Customize..., and Options....
  • Window menu contains commands for the display window.
  • Help menu contains links to the OpenOffice Help file, What’s This?, and information about the program. One can use Help to learn about Writer.
  • Toolbars

Many toolbars displaying shortcut buttons are available to make editing and formatting quicker and easier. Writer has several types of toolbars. The toolbar displayed on top position is called the Standard toolbar. The Standard toolbar is consistent across the OpenOffice applications (Writer, Calc, Draw, Impress, Base).

The second toolbar across the top is the Formatting toolbar. It is a context-sensitive bar that shows the relevant tools in response to the cursor’s current position or selection. For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting text. The formatting toolbars are floating means you can display or hide these toolbars.

  • Displaying or hiding toolbars

To display or hide toolbars, select View > Toolbars, then click on the name of a toolbar in the list. An active toolbar shows a check mark beside its name.

  • Status bar

The Writer Status bar provides information about the document and convenient ways to quickly change some document features.

Writer-3.png
Status bar
  • Page number

Shows the current page number, the sequence number of the current page (if different), and the total number of pages in the document. For example, if you restarted page numbering at 1 on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of such bookmarks; now click on the required one.

To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the sequence number of the required page. After a brief delay, the display jumps to the selected page.

  • Page style

Shows the style of the current page. To change the page style, right-click on this field. A list of page styles pops up; choose a different style by clicking on it. To edit the current page style, double-click on this field.

  • Language

Shows the language for the selected text. Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose None (Do not check spelling) to exclude the text from a spelling check or choose More... to open the Character dialog.

Insert mode

Click to toggle between Insert and Overwrite modes when typing.

Selection mode

Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection. EXT is an alternative to Shift+click when selecting text.

'Unsaved changes ' An asterisk (*) appears here if changes to the document have not been saved.

Writer-4.png
Status bar

Digital signature

If the document has been digitally signed, an iconWriter-5.png shows here. You can double-click the icon to view the certificate.

Section or object information

When the cursor is on a section, heading, or list item, or when an object (such as a picture or table) is selected, information about that item appears in this field. Double-clicking in this area opens a relevant dialog.

View layout

Click an icon to change between single page, side-by-side, and book layout views. You can edit the document in any view.

Writer-6.png
view layout

Zoom

To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.

Writer-7.png
Zoom Slider

Document View

Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access these and other choices, go to the View menu and click on the required view. (When in Full Screen view, press the Esc key to return to either Print or Web Layout view.)

When in Print Layout, you can use both the Zoom slider and the View Layout icons on the status bar. In Web Layout, you can use the Zoom slider.

You can also choose View > Zoom from the menu bar to display the Zoom & View Layout dialog, where you can set the same options as on the Status bar. In Web Layout view, most of the choices are not available

Writer.png
Zoom layout
Previous Page Home Page Next Page
ICT Applications