Virtual Open Schooling Online courses available at Virtual Open Schooling (VOS), for more details kindly click here!
NIOS Silver Jubilee Year
NIOS

Difference between revisions of "/Office Productivity Tools"

From NIOS
Jump to: navigation, search
(ENTER DATA INTO A TABLE)
Line 1: Line 1:
<div style="text-align:center;font-weight:bold;padding:0.4em 1em 0.3em 1em;-moz-border-radius: 6px;background-color:#47b8b8; ">ICT Applications</div>
+
 
{| style="float:right;margin:1em;width:250px;"
+
__NOTOC__
 +
{| class="wikitable" style="float:right;margin:1em;width:300px;"
 +
|-
 +
! [[INTEXT QUESTIONS : BASIC CONCEPTS OF COMPUTER|Previous Page]] !! [[ICT-Application| Home Page]] !! [[DATA COMMUNICATION| Next Page]]
 +
|-
 +
|}<div style="text-align:center;font-weight:bold;padding:0.4em 1em 0.3em 1em;-moz-border-radius: 6px;background-color:#47b8b8; ">ICT Applications</div>
 +
{| style="width:100%;"
 
|-
 
|-
 
|
 
|
__TOC__
+
{|style="border-spacing:10px;width:100%;"
|}
+
|class="MainPageBG" style="width:25%;border:1px solid #9999ff;background-color:#47b8b8;vertical-align:top"|
 +
{|width="100%" cellpadding="2" cellspacing="2" style="vertical-align:top;background-color:#fff"
 +
! <h2 style="margin:0;background-color:#47b8b8;font-size:120%;font-weight:bold;border:1px solid #9999ff;text-align:left;color:white;padding:0.2em 0.4em;">Topics </h2>
 +
|-
 +
|
 +
[[DATA COMMUNICATION |Office Productivity Tools]]
  
== <font color=green>Office Productivity Tools</font> ==
+
[[TYPES OF COMMUNICATION SERVICES | OpenOffice.org]]
  
There are a number of office productivity tools available both under various brand name and also through open source.  The most popular office productivity tool available under a brand name is from Microsoft office which contains Microsoft Word, Excel, PowerPoint and Access.  However under open source umbrella, Apache OpenOffice is the leading open-source office productivity suite available for word processing, spreadsheets, presentations, graphics, databases and more. It also supports many languages and can be downloaded from Internet and used completely free of cost for any purpose.
+
[[COMPUTER NETWORK | The advantages of OpenOffice]]
  
== <font color=green>OpenOffice.org</font>==
+
[[TELECONFERENCING | How to get and install OpenOffice ]]
  
The Apache OpenOffice software is freely available for download at www.openoffice.org on Internet as full-featured office productivity tools. OpenOffice can also open and save documents in many other formats, including those used by several versions of Microsoft Office which makes it compaitable to most of the avlaibel office productivity tools. This helps the user to work with various format of documents in OpenOffice smoothly without worrying much about the covrension of the document from one format to another. OpenOffice is also works on Linux and Microsoft Windows platform.
+
[[COMPUTER NETWORK | Starting OpenOffice]]
  
OpenOffice includes the following components.
+
[[COMPUTER NETWORK | Getting Started with OpenOffice Writer]]
  
#Writer  - Word Processor
+
[[COMPUTER NETWORK | Working with text]]
#Calc    - Spreadsheet
+
#Impress - Presentation tool
+
#Base    - Database
+
#Math    - Formula Editor
+
  
Let understand the funationality of these OpenOffice tools.
+
[[COMPUTER NETWORK | Starting OpenOffice]]
  
''' Writer (word processor)'''
+
[[COMPUTER NETWORK | Starting OpenOffice]]
 +
|}
 +
|class="MainPageBG" style="width:50%;border:1px solid #9999ff;background-color:white ;vertical-align:top"|
 +
{| width="100%" cellpadding="2" cellspacing="2" style="vertical-align:top;background-color:white "
 +
|-
 +
==<font color=green>INTRODUCTION</font>==
  
Writer is the word processor component of the OpenOffice Suite. It is used for creating document such as letters, books, reports, newsletters, brochures, and other documents. It has all the features of a word processor such as spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic generation of tables of contents and indexes, mail merge, and many others. You can insert graphics and objects from other components into Writer documents. Writer can export files to HTML, XHTML, XML, Adobe’s Portable Document Format (PDF), and several versions of Microsoft Word files. It also connects to your email client.
+
Computers are used to generate information. Generated information is not useful in itself. The information must be delivered to the right person at the right time. Often information must be transmitted from one location to another. This process is called data communication. Here, we will be concerned with the hardware, software and procedures used in data communication.
  
''' Calc (spreadsheet)'''
+
Communications, the transfer of information, is the basic of office automation. Advances in communication technology, combined with rapidly evolving computer technology, have made possible much of the progress in the field. Electronic communication consists of telecommunication and data communications. Telecommunication refers to the use of telephone, telegraph, and radio or television facility to transmit information, either directly or via computer. Data communication means the transfer of data or information between computers devices.
  
Calc is the spreadsheet component of the OpenOffice Suite. Calc has all of the advance analysis, charting, and decision-making features expected from a high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2-D and 3-D charts, which can be integrated into other OpenOffice documents as well. You can also open and work with Microsoft Excel workbooks and save them in Excel format. Calc can export spreadsheets to Adobe’s PDF and to HTML.
+
==<font color=green>OBJECTIVES</font>==
  
''' Impress (presentations)'''
+
After going through this lesson, you would be able to:
  
Impress is the tools to create presentation in OpenOffice. Impress provides all the common multimedia presentation tools, such as special effects, animation, and drawing tools. Slide shows can be further enhanced with sound and video clips. Impress is compatible with Microsoft’s PowerPoint file format and can also save your work in numerous graphics formats, including Macromedia Flash (SWF).
+
* learn the basic elements of data communication system.  
 +
* describe communication protocols and data transmission modes.  
 +
* explain the use of computer network.  
 +
* describe different component of computer network
 +
* identify different types of network
  
''' Base (Database)'''
+
<h2 style="color:#9999ff;font-weight:bold"></h2>
 +
|}
 +
|class="MainPageBG" style="width:35%;border:1px solid #805817;background-color:#fff;vertical-align:top"|
  
Base is the database component of the OpenOffice Suite.  It provides tools for day-to-day database work within a simple interface. It can create and edit forms, reports, queries, tables, views, and relations, so that managing a connected database is much the same as in other popular database applications. You can also use dBASE, Microsoft Access, MySQL, or Oracle, or any ODBC-compliant or JDBC-compliant database in Base.  
+
<mediaplayer width='300' height='200'>File:1.flv</mediaplayer>
  
''' Math (formula editor)'''
+
|}
  
Math is the formula or equation editor of the OpenOffice Suite. You can use it to create complex equations that include symbols or characters usually not available in standard font sets. While it is most commonly used to create formulas in other documents, such as Writer and Impress files, Math can also work as a standalone tool. You can save formulas in the standard Mathematical Markup Language (MathML) format for inclusion in web pages and other documents not created by OpenOffice.
+
{| class="wikitable" style="float:right;margin:1em;width:300px;"
 
+
|-
==<font color=green> The advantages of OpenOffice</font>==
+
! [[INTEXT QUESTIONS : BASIC CONCEPTS OF COMPUTER|Previous Page]] !! [[ICT-Application| Home Page]] !! [[DATA COMMUNICATION| Next Page]]
 
+
|-
Here are some of the advantages of OpenOffice Suite over other Office Producvity Suites:
+
|}<div style="text-align:center;font-weight:bold;padding:0.4em 1em 0.3em 1em;-moz-border-radius: 6px;background-color:#47b8b8; ">ICT Applications</div>
 
+
* '''No license fees'''. OpenOffice is free for anyone to use and distribute at no cost. Many features that are available as 'extra cost add-ins' in other office suites (like PDF export) are free with OpenOffice. 
+
 
+
* '''Open Source'''. You can distribute, copy, and modify the software as much as you wish, in accordance with either of OpenOffice’s Open Source licenses.
+
 
+
* '''Cross-Platform'''. OpenOffice runs on several hardware architectures and under multiple operating systems, such as Microsoft Windows, Mac OS X, Linux, and Solaris.
+
 
+
* '''Extensive Language Support'''. OpenOffice’s user interface is available in over 40 different languages, and the OOo project provides spelling, hyphenation, and thesaurus dictionaries in over 70 languages and dialects. OpenOffice also provides support for both Complex Text Layout (CTL) and Right to Left (RTL) layout languages (such as Urdu, Hebrew, and Arabic).
+
 
+
* '''Consistent User Interface'''. All the components of OpenOffice Suite have a similar “look and feel,” making them easy to use and master.
+
 
+
* '''Integration'''. The components of OpenOffice are well integrated with one another. All the components share a common spelling checker and other tools, which are used consistently across the suite. For example, the drawing tools available in Writer are also found in Calc, with similar but enhanced versions in Impress and Draw. You do not need to know which application was used to create a particular file. For example, you can open a Draw file from Writer.
+
 
+
* '''File Compatibility'''. In addition to its native OpenDocument formats, OpenOffice includes PDF and Flash export capabilities, as well as support for many common file formats including Microsoft Office, HTML, XML, WordPerfect, and Lotus 1-2-3.
+
 
+
==<font color=green> How to get and install OpenOffice</font>==
+
 
+
The OpenOffice Suite is an open source software available free of any charge and can be downloaded from OpenOffice.org.  However, now a days, many new computers comes pre-loaded with OpenOffice as an alternative. The lattest release is version 3.4 of OpenOffice Suite. and is available for download. One can also purchase a copy on a CD or DVD from a third-party distributor.
+
 
+
 
+
[[File:openofficedownload.png |800px|thumb|centre]]
+
 
+
Click on the 2nd option for downloading the OpenOffice from its home page as shown in the above screen shot. The downloaded file is an executable file with name '''Ooo_3.3.0_win_x86_install-wJRE_en-US.exe'''
+
 
+
For installation double click this '''exe''' file and it will install the OpenOffice on your computer and will also create a shortcut on your desktop.
+
 
+
The installation instructions of OpenOffice.org on various supported operating system is available here: http://download.openoffice.org/common/instructions.html.
+
 
+
==<font color=green>Starting OpenOffice</font>==
+
 
+
The most common way to start any component of OpenOffice on Linux platform is by using the system menu, it is the standard menu from which most applications are started. On Windows platform, it is called the Start Menu and on Mac OS X, it is known as the Applications Menu. 
+
 
+
When OpenOffice is installed on a computer,  it creates a separate menu entry under System Menu for each of the OpenOffice component. 
+
 
+
Go to '''Start Menu -> All Programmes -> OpenOffice'''
+
 
+
 
+
[[File:file.png|500 px|centre|alt text]]             
+
 
+
 
+
From the above menu you can click on the desired component of the OpenOffice to start the program.  You can also go to the desired component directly from the start menu in the following ways:
+
 
+
* Start menu->All Programmes->OpenOffice->OpenOffice '''Base'''
+
* Start menu->All Programmes->OpenOffice->OpenOffice '''Calc'''
+
* Start menu->All Programmes->OpenOffice->OpenOffice '''Impress'''
+
* Start menu->All Programmes->OpenOffice->OpenOffice '''Writer'''
+
 
+
=<font color=green> Getting Started with OpenOffice Writer</font>=
+
 
+
 
+
 
+
Writer is the word processor component of the OpenOffice Suite. It allows you to various kind of documents such as letters, reports, newsletters, tables, form letters, brochures, and web pages. Writer has all the features of any standard word processor such as spelling check, thesaurus, hyphenation, auto-correct, find and replace, automatic generation of tables of contents and indexes, mail merge and others. In addition to the standard features of a word processor, Writer also provides many more important features to create professional documents.
+
 
+
==<font color=green> Objectives</font>==
+
 
+
After going through this lesson you would be able to:
+
* explain basic features of Writer, word processor of OpenOffice Suite
+
* define Writer’s document defaults;
+
* move around in a document more quickly and efficiently;
+
* manage Writer files and printing.
+
 
+
== <font color=green>Main Features of OpenOffice Writer</font> ==
+
* Create documents fast, using built-in and custom templates and styles. 
+
* Manage large documents using various features like the ability to create table of contents, index, and cross references.;
+
* With the help of mail merge, quickly create and merge documents for mass mailings or create mailing labels;
+
* Easily create and format tables using the features like AutoFormat.
+
* Auto-Correct and Auto-Format features rectify typo-graphical errors automatically and allows to use predefined shortcuts and typing patterns to quickly format the documents.
+
* It allows embedding or linking of graphics, spreadsheets, and other objects.
+
* The print zoom facility scales a document on different paper sizes, and allows to print out multiple pages on a single sheet of paper.
+
* The nested tables feature supports putting one table inside another table.
+
* The picture bullets make it easy to insert tiny pictures before each item in a list.
+
* Collect and paste lets copy more than one item to the clipboard at a time. One can collect information from many sources and paste it into one place.
+
* By putting Writer documents on the Web server, one can share information with other people.
+
* The multilingual features of Writer allows to type different languages in the same document.
+
* Save documents in HTML format. Also create Web Pages using Web Page Wizard.
+
* Writer has a powerful feature of built-in drawing tools which allows to create various drawings and graphics.
+
* Export your Writer document to PDF including bookmarks.
+
 
+
== <font color=green> Starting OpenOffice Writer</font> ==
+
 
+
You can start your OpenOffice.org Writer in may ways. The most common way of starting any program is by using System Menu through Start button:
+
 
+
1. Click on the Start button.
+
 
+
2. Start menu->All Programmes->OpenOffice->OpenOffice.org Writer.
+
 
+
In few seconds you will see OpenOffice.org Writer screen on the monitor.
+
 
+
You can also start your OpenOffice.org Writer program by simply clicking on OpenOffice.org Shortcut on your desktop and then click the Text Document.
+
 
+
'''Starting from an existing document'''
+
 
+
You can start OpenOffice.org by double-clicking the filename of an OpenOffice.org document in a file manager such as Windows Explorer. The appropriate component of OpenOffice.org will start and the document will be loaded.
+
 
+
You can spot an OpenOffice.org Writer document by its icon: [[File:writer-2.png]]
+
 
+
'''Note for Windows users'''
+
 
+
If you have associated Microsoft Office file types with OpenOffice.org, then when you double-click on a *.doc (Word) file, it opens in Writer; *.xls (Excel) files open in Calc, and *.ppt (PowerPoint) files open in Impress.
+
 
+
==<font color=green> OpenOffice Writer Interface</font>==
+
 
+
The main screen of OpenOffice Writer workspace contains a number of menu objects.  We will discuss the main Writer workspace in Print Layout (shown in Figure 2.1) here.
+
 
+
[[File:writer-1.png |500px|centre|]]
+
 
+
 
+
'''  Menus'''
+
 
+
The '''Menu bar''' is located across the top of the Writer window, just below the Title bar. When you choose one of the menus listed below, a sub-menu drops down to show the commands for that sub-menu.
+
 
+
* '''File''' menu contains commands that apply to the entire document such as '''Open..., Save, and Export  as PDF....'''
+
 
+
* '''Edit''' menu contains commands for editing the document such as '''Undo: xxx''' (where xxx is the command to undo) and '''Find & Replace'''.... It also contains commands to '''cut, copy, and paste''' selected parts of your document.
+
 
+
* '''View''' menu contains commands for controlling the display of the document such as '''Zoom...''' and Web Layout.
+
 
+
* '''Insert''' menu contains commands for inserting elements into your document such as '''headers, footers, and pictures.'''
+
 
+
* '''Format''' menu contains commands for formatting the layout of your document, such as '''Styles and Formatting, Paragraph, and Bullets and Numbering'''.
+
 
+
* '''Table''' menu shows all commands to insert and edit a table in a text document.
+
 
+
* '''Tools''' menu contains functions such as '''Spelling and Grammar, Customize..., and Options'''....
+
 
+
* '''Window''' menu contains commands for the display window.
+
 
+
* '''Help''' menu contains links to the OpenOffice Help file, What’s This?, and information about the program. One can use '''Help''' to learn about Writer.
+
 
+
* '''Toolbars'''
+
 
+
Many toolbars displaying shortcut buttons are available to make editing and formatting quicker and easier.  Writer has several types of toolbars.  The toolbar displayed on top position is called the Standard toolbar. The Standard toolbar is consistent across the OpenOffice applications (Writer, Calc, Draw, Impress, Base).
+
 
+
The second toolbar across the top is the Formatting toolbar. It is a context-sensitive bar that shows the relevant tools in response to the cursor’s current position or selection. For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting text.  The formatting toolbars are floating means you can display or hide these toolbars. 
+
 
+
* '''Displaying or hiding toolbars'''
+
 
+
To display or hide toolbars, select View > Toolbars, then click on the name of a toolbar in the list. An active toolbar shows a check mark beside its name.
+
 
+
* '''Status bar'''
+
 
+
The Writer Status bar provides information about the document and convenient ways to quickly change some document features.
+
 
+
[[File:writer-3.png |500px|centre|]]
+
 
+
* '''Page number'''
+
 
+
Shows the current page number, the sequence number of the current page (if different), and the total number of pages in the document. For example, if you restarted page numbering at 1 on the third page, its page number is 1 and its sequence number is 3.
+
 
+
If any bookmarks have been defined in the document, a right-click on this field pops up a list of such bookmarks; now click on the required one.
+
 
+
To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the sequence number of the required page. After a brief delay, the display jumps to the selected page.
+
 
+
* '''Page style'''
+
 
+
Shows the style of the current page. To change the page style, right-click on this field. A list of page styles pops up; choose a different style by clicking on it. To edit the current page style, double-click on this field. 
+
 
+
* '''Language'''
+
 
+
Shows the language for the selected text. Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose None (Do not check spelling) to exclude the text from a spelling check or choose More... to open the Character dialog.
+
 
+
'''Insert mode'''
+
 
+
Click to toggle between Insert and Overwrite modes when typing.
+
 
+
'''Selection mode'''
+
 
+
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection. EXT is an alternative to Shift+click when selecting text.
+
 
+
'''Unsaved changes''
+
'
+
An asterisk (*) appears here if changes to the document have not been saved.
+
 
+
[[File:Writer-4.png]]
+
 
+
'''Digital signature'''
+
 
+
If the document has been digitally signed, an icon[[File:writer-5.png]]  shows here. You can double-click the icon to view the certificate.
+
 
+
'''Section or object information'''
+
 
+
When the cursor is on a section, heading, or list item, or when an object (such as a picture or table) is selected, information about that item appears in this field. Double-clicking in this area opens a relevant dialog.
+
 
+
'''View layout'''
+
 
+
Click an icon to change between single page, side-by-side, and book layout views. You can edit the document in any view.
+
 
+
[[File:Writer-6.png |centre|]]
+
 
+
'''Zoom'''
+
 
+
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.
+
 
+
[[File:writer-7.png |centre|]]
+
 
+
'''Document View'''
+
 
+
Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access these and other choices, go to the View menu and click on the required view. (When in Full Screen view, press the Esc key to return to either Print or Web Layout view.)
+
 
+
When in Print Layout, you can use both the Zoom slider and the View Layout icons on the status bar. In Web Layout, you can use the Zoom slider.
+
 
+
You can also choose '''View > Zoom''' from the menu bar to display the Zoom & View Layout dialog, where you can set the same options as on the Status bar. In Web Layout view, most of the choices are not available
+
 
+
[[File:writer.png | 500px |centre|]]
+
 
+
=<font color=green> Managing Documents</font> =
+
 
+
This section of the lesson explains how to open a new/existing document, save a document, renaming a document, working with multiple documents, protecting a document, finding a document, and
+
closing a opened document. There are several ways to create a new document, open existing documents, and save documents in OpenOffice Writer.
+
 
+
 
+
== <font color=green>Starting a new document </font >==
+
 
+
You can start a new, blank document in OpenOffice Writer in several ways.
+
 
+
One way is to start OpenOffice and click on the Text Document icon of the Start Center as shown in the figure starting OpenOffice Suite. You can also  click the Templates icon to start a new document using a template.
+
 
+
You can also start a new document in one of the following ways.
+
1. Use '''File > New''' and choose the type of document.
+
2. Use the '''arrow next''' to the '''New''' button on the main toolbar. From the drop-down menu, select the  type of document to be created.
+
3. Press '''Control+N''' on the keyboard.
+
4. Use File > Wizards for some special types of documents.
+
 
+
If a document is already open in OpenOffice Writer, the new document opens in a new window.
+
 
+
== <font color=green>Opening an existing document </font >==
+
 
+
When no document is open, the Start Center provides an icon for opening an existing document or choosing from a list of recently-edited documents.
+
 
+
[[File:writer-10.png |centre|]]
+
 
+
 
+
You can also open an existing document in one of the following ways.
+
 
+
* Choose '''File > Open...'''
+
* Click the '''Open''' button on the main toolbar.
+
* Press '''Control+O''' on the keyboard.
+
 
+
In each case, the Open dialog appears. Select the file you want, and then click Open. If a document is already open in OpenOffice Writer, the second document opens in a new window.
+
 
+
You can also open an existing document that is in an OpenDocument format by double-clicking on the file’s icon on the desktop or in a file manager such as Windows Explorer.
+
 
+
If you have associated Microsoft Office file formats with OOo, you can also open these files by double-clicking on them.
+
 
+
== <font color=green>Saving a document </font >==
+
 
+
To save a new document, you can do one of the following:
+
 
+
- Press '''Control+S'''.
+
- Choose '''File > Save''' from the menu bar.
+
- Click the '''Save''' button on the main toolbar.
+
- When the Save As dialog appears, enter the file name, verify the file type (if applicable), and click '''Save'''.
+
 
+
To save an open document with the current file name, choose '''File > Save'''. This will overwrite the last saved state of the file.
+
 
+
'''Password protection :-'''
+
 
+
You can protect your entire document with a password. For this use the option on the '''Save As dialog''' to enter a password.
+
 
+
- On the '''Save As dialog''', select the '''Save with password option''', and then click '''Save'''.  You will receive a Set Password window.
+
 
+
[[File:writer-11.png |centre|]]
+
 
+
- Enter a password in the field '''Enter password''' to open and then enter the same password in the second field '''Confirm password''' and then click '''OK'''. If the passwords match, the document is saved as password protected. If the passwords do not match, you receive an error message. Close the message box to return to the Set Password dialog box and enter the password again.
+
 
+
'''Saving as a Microsoft Word file:-'''
+
 
+
You can share OpenOffice document files with users of Microsoft Word by saving the file selecting Word format under File type or Save as type. You can save a document as a Microsoft Word file in the following manner:
+
 
+
- Select File > Save As. On the Save As dialog, in the File type (or Save as type) drop-down menu, select the type of Word format you need. Click Save.
+
 
+
[[File:writer-12.png |centre|]]
+
 
+
It is important to note that after saving the file as Word format, all changes you make to the document will occur only in the Microsoft Word document. You have changed the name and file type of your document. If you want to go back to working with the .odt version of your document, you must open it again.
+
 
+
You can also change the default setting of your document to save in the Microsoft Word file.  For this go to '''Tools > Options > Load/Save'''. 
+
 
+
Select the option of '''Microsoft office''' from its “'''Choosing options for loading and saving documents'''”.  This will set your document to be saved in Microsoft Word format by default.
+
 
+
=<font color=green>Working with text</font > =
+
 
+
In this chapter we will be discussing very important part of the OpenOffice writer document regarding working with text such as selecting, copying, pasting, moving text.  These functions in Writer are similar to working with text in any other program. OpenOffice writer has some convenient ways to select items that are not next to each other, select a vertical block of text, and paste unformatted text.
+
 
+
== <font color=green>Cutting, copying, and pasting text</font > ==
+
 
+
'''Cutting and copying''' text in Writer is similar to cutting and copying text in other word processing applications such as MS-Word. You can use the mouse or the keyboard for these operations. You can copy or move text within a document, or between documents, by dragging or by using menu selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.
+
 
+
To move - '''cut and paste''' selected text using the mouse, drag it to the new location and release it. To copy selected text, hold down the Control key while dragging. The text retains the formatting it had before dragging.
+
 
+
When you paste text, the result depends on the source of the text and how you paste it. If you click on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from Web sites and other sources may also be placed into frames or tables. If you do not like the results, click the Undo icon or press Control+Z.
+
 
+
To make the pasted text take on the formatting of the surrounding text where it is being pasted, choose either:
+
 
+
- Edit > Paste Special, or
+
- Click the triangle to the right of the Paste icon, or
+
- Click the Paste icon without releasing the left mouse button.
+
 
+
Then select Unformatted text from the resulting menu.
+
 
+
== <font color=green>Find and Replace Text  </font > ==
+
 
+
Writer has two ways to find text within a document.  You can use either the '''Find toolbar''' for fast searching and the '''Find & Replace dialog'''.
+
In the dialog, you can:
+
- '''Find and replace''' words and phrases
+
- You can use wildcards and regular expressions to fine-tune a search
+
- Find and replace specific formatting
+
- Find and replace paragraph styles
+
 
+
[[File:writer-13.png |right|]]
+
If the '''Find toolbar''' is not visible, you can display it using '''View > Toolbars > Find'''
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
To display the Find & Replace dialog, use the keyboard shortcut '''Control+F''' or choose '''Edit > Find & Replace''' from the menu bar.
+
 
+
 
+
[[File:writer-14.png |centre|]]
+
 
+
 
+
- Type the text you want to find in the '''Search for''' box.
+
 
+
- To replace the text with different text, type the new text in the '''Replace with box'''.
+
 
+
- You can select various options such as '''matching the case''', '''matching whole words only''', or doing a search for '''similar words'''.
+
 
+
- After you have set up your search, click '''Find'''. To replace text, click '''Replace''' instead.
+
 
+
Kindly note that, if you click '''Find All''', OpenOffice Writer selects all instances of the search text in the document. Similarly, if you click '''Replace All''', OpenOffice writer replaces all matches.
+
 
+
== <font color=green>Tab Setting and indents </font > ==
+
 
+
Tab settings affect indentation of full paragraphs using the Increase Indent and Decrease Indent icons on the Formatting toolbar.  It also affects parts of a paragraph by pressing the Tab key on the keyboard.
+
 
+
To define indents and tab settings for one or more selected paragraphs, double-click on a part of the ruler that is not between the left and right indent icons to open the '''Indents & Spacing''' page of the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to open the Tabs page of the Paragraph dialog.  You can also do this by clicking  '''Format > Paragraph > Indent & Spacing'''
+
 
+
You can also define tabs for the paragraph style by clicking '''Format > Paragraph > Tab'''.
+
 
+
In order to set the measurement unit and the spacing of default tab stop intervals, go to '''Tools > Options > OpenOffice.org Writer > General'''.
+
 
+
[[File:writer-15.png |centre|]]
+
 
+
= <font color=green>OpenOffice Base (Database)</font > =
+
In this lesson we will be dicussing one of the important office productivity tools viz., Database Management.
+
 
+
One of the most powerful applications of computers is its capability to store, organize, and retrieve large quantities of data. An organized collection of related data is referred to as a database. A database is a collection of objects that allow you to store data, organize it and retrieve it in any way you want.
+
 
+
== <font color=green>Objectives</font> ==
+
 
+
 
+
After going through this lesson you would be able to:
+
* explain the terms like database, table, record, field, datatype;
+
* create a database from scratch or using template;
+
* create tables for data entry in datasheet view and design view;
+
* create queries using wizard and design view;
+
* create a Form using various tools;
+
* create report in different ways;
+
* create presentations using different types of slides;
+
* add various multimedia factures to slide;
+
* save and print a database, query reports, and presentation'''
+
 
+
==<font color=green> STARTING OPEN OFFICE.ORG DATABASE PROGRAM</font> ==
+
 
+
You can start the openoffice.org databse in different ways. One way is using Start button:
+
 
+
1. Click on the Start button.
+
 
+
2. In the menu that appears select All Programs→OpenOffice.org → OpenOffice.org dabase as shown in (Fig.5.1).
+
 
+
Fig 5.1
+
 
+
 
+
After clicking OpenOffice.org dabase , you will see Getting Started with OpenOffice.org dabase screen on the monitor.
+
 
+
+
You have the following three options:
+
 
+
+
 
+
(i) Open a Blank Database
+
 
+
(ii) Open a Database template
+
 
+
(iii) Open a Recent Database
+
 
+
'''4.3.1 Creating a Database from the scratch'''
+
 
+
Choose the option Open a Blank Database for creating a Database from the scratch.
+
 
+
1. Blank database with the default name Database1 appears as shown in Fig. 5.3.
+
 
+
FIGURE to be inserted Fig:5.3 and 5.4
+
 
+
2. Type the file name of the database e.g. NIOS_dbase (Fig 5.4).
+
 
+
(It is recommended to create a general database before creating tables and forms.)
+
 
+
3. Browse and select folder
+
 
+
4. Click Create.
+
 
+
Your database file NIOS_dbase is saved in the specified folder and opens for you to create an Access table in datasheet view (Fig 5.5).
+
 
+
'''4.3.2 Creating a Database using Template'''
+
 
+
You can create a database by using Template in following ways:
+
 
+
(i) Select suitable Featured Online Templates from the relevant Template Category as shown earlier in Fig. 5.2.
+
 
+
(ii) In the Ribbon click Create tab as shown in Fig. 5.6 (a)and in the Tables group bring cursor at Table Templates (Fig. 5.6(b)) and click it. Then select and click the desired Template from the drop down list of template as shown in Fig. 5.6 (c) and the template opens as shown in Fig. 5.6(d).
+
Fig: 5.6(a),(b),(c),(d)
+
 
+
'''4.3.3 To Open an Existing Database'''
+
Click a database in the Open Recent Database list as shown earlier in Fig. 5.2 or click More and browse for the desired database.
+
 
+
== <font color=green>HOW ACCESS STORES DATA IN TABLES</font> ==
+
 
+
Access 2007 stores data in tables which look more like the cells of a spreadsheet with columns and rows. Each row represents a record, and each column represents a field. Table 5.1 is an example of a Table having Details of Students. In this Students database each student would be considered a record and each record (student) consists of headings or categories called fields or attributes, and each record in the database is formatted in the same way
+
 
+
== <font color=green> ENTER DATA INTO A TABLE</font>==
+
 
+
Once a table has been created, data can be entered.
+
 
+
1. If your new table is not open, double click on its title, in the Navigation Pane.
+
 
+
2. In the Home tab→Views group, select Datasheet View. (The default view for a new table is Datasheet view.)
+
 
+
3. The first field (column) is automatically named ID, the data type is AutoNumber and it is the assigned Primary Key. Generally Primary keys are not required but they are needed to combine two or more tables, columns, or rows in a database. Primary key is a unique number, i.e., it cannot be duplicated.
+
 
+
4. Double click on Add New Field and type in the new field name F_name for the First Name, L_name for Last name of the student and so on as given in Table 5.1. When entering field names, do not use spaces or punctuation.
+
 
+
5. Type in Sohan, in the first row under the field F_name.
+
 
+
6. The Data Type is set to Text. While entering numbers or date, the data type would be set to Number or Date and Time and so on.
+
 
+
Complete the table by entering data (as given in Table 5.1). The screen will look like Fig 5.7.
+
<div style="text-align:center;font-weight:bold;padding:0.4em 1em 0.3em 1em;-moz-border-radius: 6px;background-color:#47b8b8; ">ICT Applications</div>
+
[[Category:TOPICS]]
+

Revision as of 10:45, 30 July 2012


Previous Page Home Page Next Page
ICT Applications

Topics

Office Productivity Tools

OpenOffice.org

The advantages of OpenOffice

How to get and install OpenOffice

Starting OpenOffice

Getting Started with OpenOffice Writer

Working with text

Starting OpenOffice

Starting OpenOffice

INTRODUCTION

Computers are used to generate information. Generated information is not useful in itself. The information must be delivered to the right person at the right time. Often information must be transmitted from one location to another. This process is called data communication. Here, we will be concerned with the hardware, software and procedures used in data communication.

Communications, the transfer of information, is the basic of office automation. Advances in communication technology, combined with rapidly evolving computer technology, have made possible much of the progress in the field. Electronic communication consists of telecommunication and data communications. Telecommunication refers to the use of telephone, telegraph, and radio or television facility to transmit information, either directly or via computer. Data communication means the transfer of data or information between computers devices.

OBJECTIVES

After going through this lesson, you would be able to:

  • learn the basic elements of data communication system.
  • describe communication protocols and data transmission modes.
  • explain the use of computer network.
  • describe different component of computer network
  • identify different types of network

The media player is loading...

Previous Page Home Page Next Page
ICT Applications